安装rrdtool时候的报错configure: error: Please fix the library issues listed above and try again

configure: error: Please fix the library issues listed above and try again.
解决方法:
第一:
安装 cgilib-0.5.tar.gz
从这里下载:
weget http://download.chinaunix.net/down.php?id=2531&ResourceID=1333&site=1
tar zxvf cgilib-0.5.tar.gz
cd cgilib-0.5
make
cp libcgi.a /usr/local/lib
cp cgi.h /usr/include
如果还不行,请看
第二:
安装libart_lgpl-devel这个包
yum –y install libart_lgpl-devel
如果还报错configure: error: Please fix the library issues listed above and try again. 请看
第三:
 把这两个包装上pango-devel cairo-devel
yum –y install pango-devel* cairo-devel*
  然后在
cd cd rrdtool-X.X.X
./configure –prefix=/usr/local/rrdtool
这样肯定能行,一般在第二部就能解决了。
本站部分文章源于互联网,本着传播知识、有益学习和研究的目的进行的转载,为网友免费提供。如有著作权人或出版方提出异议,本站将立即删除。如果您对文章转载有任何疑问请告之我们,以便我们及时纠正。

PS:推荐一个微信公众号: askHarries 或者qq群:474807195,里面会分享一些资深架构师录制的视频录像:有Spring,MyBatis,Netty源码分析,高并发、高性能、分布式、微服务架构的原理,JVM性能优化这些成为架构师必备的知识体系。还能领取免费的学习资源,目前受益良多

转载请注明原文出处:Harries Blog™ » 安装rrdtool时候的报错configure: error: Please fix the library issues listed above and try again

赞 (0)
分享到:更多 ()

评论 2

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
  1. 小松博客ubuntu怎么解决这个问题啊回复
    • harries同理呀,都是Linux系统,都差不多回复