转载

[Java] 1022. Digital Library (30)-PAT甲级

1022. Digital Library (30)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;

Line #2: the book title — a string of no more than 80 characters;

Line #3: the author — a string of no more than 80 characters;

Line #4: the key words — each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;

Line #5: the publisher — a string of no more than 80 characters;

Line #6: the published year — a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

1: a book title

2: name of an author

3: a key word

4: name of a publisher

5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print “Not Found” instead.

Sample Input:

3

1111111

The Testing Book

Yue Chen

test code debug sort keywords

ZUCS Print

2011

3333333

Another Testing Book

Yue Chen

test code sort keywords

ZUCS Print2

2012

2222222

The Testing Book

CYLL

keywords debug book

ZUCS Print2

2011

6

1: The Testing Book

2: Yue Chen

3: keywords

4: ZUCS Print

5: 2011

3: blablabla

Sample Output:

1: The Testing Book

1111111

2222222

2: Yue Chen

1111111

3333333

3: keywords

1111111

2222222

3333333

4: ZUCS Print

1111111

5: 2011

1111111

2222222

3: blablabla

Not Found

题目大意:模拟数字图书馆的查询功能。会给出n本书的信息,以及m个需要查询的命令,数字标号对应相应的命令,数字编号后面的字符串是查询的搜索词,要求输出这行命令以及输出满足条件的书的id,如果一个都没有找到,输出Not Found

PS:感谢github用户 @fs19910227 提供的pull request~

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.HashMap;
import java.util.TreeSet;
 
public class Main {
    static BufferedReader reader = new BufferedReader(new InputStreamReader(System.in), 6 * 1024 * 1024);
 
    static class Library {
        HashMap<String, TreeSet<String>>[] allMaps = new HashMap[5];
 
        Library() throws IOException {
            for (int i = 0; i < 5; i++) {
                HashMap<String, TreeSet<String>> map = new HashMap<>(1000, 1);
                allMaps[i] = map;
            }
            int record_size = Integer.valueOf(reader.readLine());
            for (int i = 0; i < record_size; i++) {
                String id = reader.readLine();
                for (int j = 0; j < allMaps.length; j++) {
                    HashMap<String, TreeSet<String>> map = allMaps[j];
                    if (j == 2) {
                        String[] keys = reader.readLine().split(" ");
                        for (String key : keys) {
                            putValue(map, key, id);
                        }
                    } else {
                        String key = reader.readLine();
                        putValue(map, key, id);
                    }
                }
            }
        }
 
        TreeSet<String> query(int id, String queryString) {
            HashMap<String, TreeSet<String>> allMap = allMaps[id - 1];
            TreeSet<String> integers = allMap.get(queryString);
            return integers;
        }
 
        private void putValue(HashMap<String, TreeSet<String>> map, String key, String id) {
            TreeSet<String> integers = map.computeIfAbsent(key, k -> new TreeSet<>());
            integers.add(id);
        }
    }
 
    public static void main(String[] args) throws IOException {
        Library library = new Library();
        int query_size = Integer.valueOf(reader.readLine());
        for (int i = 0; i < query_size; i++) {
            String line = reader.readLine();
            System.out.println(line);
            int id = line.charAt(0) - 48;
            String query = line.substring(3);
            TreeSet<String> queryResult = library.query(id, query);
            if (queryResult == null) {
                System.out.println("Not Found");
            } else {
                for (String book_id : queryResult) {
                    System.out.println(book_id);
                }
            }
        }
    }
}
[Java] 1022. Digital Library (30)-PAT甲级

(随着网站访问量的激增,服务器配置只得一再升级以维持网站不“404 Not Found”,所以网站的维护费用也在不断上涨……(目前的阿里云服务器ECS+云数据库RDS+域名购买+七牛云的费用是2200元/年),为了能不放弃该网站,所以我又把打赏链接放上来啦~所有打赏金额都会被记账并投入博客维护中,感谢厚爱,多多关照~)

原文  https://www.liuchuo.net/archives/4994
正文到此结束
Loading...