转载

第九届蓝桥杯Java B——递增三元组

给定三个整数数组

A = [A1, A2, ... AN],

B = [B1, B2, ... BN],

C = [C1, C2, ... CN],

请你统计有多少个三元组(i, j, k) 满足:

  1. 1 <= i, j, k <= N
  2. Ai < Bj < Ck

【输入格式】

第一行包含一个整数N。

第二行包含N个整数A1, A2, ... AN。

第三行包含N个整数B1, B2, ... BN。

第四行包含N个整数C1, C2, ... CN。

对于30%的数据,1 <= N <= 100

对于60%的数据,1 <= N <= 1000

对于100%的数据,1 <= N <= 1000000 <= Ai, Bi, Ci <= 100000

【输出格式】

一个整数表示答案

【输入样例】

3

1 1 1

2 2 2

3 3 3

【输出样例】

27

资源约定:

峰值内存消耗(含虚拟机) < 256M

CPU消耗 < 1000ms

把a数组升序排序,c数组降序排序,然后遍历b数组,找a数组有多少个比b数组小,再找c数组有多少个比b数组大

import java.io.BufferedInputStream;
import java.util.Arrays;
import java.util.Collections;
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner cin = new Scanner(new BufferedInputStream(System.in));
        int n = cin.nextInt();
        int[] a = new int[n];
        int[] b = new int[n];
        Integer[] c = new Integer[n];
        long ans = 0L;
        for (int i = 0; i < n; i++)
            a[i] = cin.nextInt();
        for (int i = 0; i < n; i++)
            b[i] = cin.nextInt();
        for (int i = 0; i < n; i++)
            c[i] = cin.nextInt();
        Arrays.sort(a);
        Arrays.sort(c, Collections.reverseOrder());

        int[] resa = new int[n];
        int[] resc = new int[n];
        for (int i = 0; i < n; i++) { // traverse B
            for (int j = 0; j < n; j++) // traverse A
                if (a[j] < b[i])
                    resa[i]++;
                else
                    break;

            for (int j = 0; j < n; j++) // traverse C
                if (c[j] > b[i])
                    resc[i]++;
                else
                    break;
        }
        for (int i = 0; i < n; i++)
            ans += resa[i] * resc[i];
        System.out.println(ans);
    }
}
原文  https://www.wmathor.com/index.php/archives/1292/
正文到此结束
Loading...