转载

[Java] 1019. General Palindromic Number (20)-PAT甲级

1019. General Palindromic Number (20)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line “Yes” if N is a palindromic number in base b, or “No” if not. Then in the next line, print N as the number in base b in the form “ak ak-1 … a0”. Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes

1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No

4 4 1

题目大意:给出两个整数a和b,问十进制的a在b进制下是否为回文数。是的话输出Yes,不是输出No。并且输出a在b进制下的表示,以空格隔开

PS:感谢github用户 @fs19910227 提供的pull request~

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;
 
public class Main {
    private static ArrayList<Integer> toPalindromic(int number, int base) {
        ArrayList<Integer> list = new ArrayList<>(31);
        if (number == 0) {
            list.add(0);
            return list;
        }
        while (number != 0) {
            int bit = number % base;
            list.add(bit);
            number = number / base;
        }
        return list;
    }
 
    static boolean isPalindromic(ArrayList<Integer> list) {
        int length = list.size();
        for (int i = 0, j = length - 1; i < length / 2; i++, j--) {
            if (!list.get(i).equals(list.get(j))) {
                return false;
            }
        }
        return true;
    }
 
    public static void main(String[] args) throws IOException {
        BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
        String[] split = reader.readLine().split(" ");
        int number = Integer.valueOf(split[0]);
        int base = Integer.valueOf(split[1]);
        ArrayList<Integer> builder = toPalindromic(number, base);
        System.out.println(isPalindromic(builder) ? "Yes" : "No");
        for (int i = builder.size() - 1; i >= 0; i--) {
            System.out.printf("%d%s", builder.get(i), i == 0 ? "/n" : " ");
        }
    }
}
[Java] 1019. General Palindromic Number (20)-PAT甲级

(随着网站访问量的激增,服务器配置只得一再升级以维持网站不“404 Not Found”,所以网站的维护费用也在不断上涨……(目前的阿里云服务器ECS+云数据库RDS+域名购买+七牛云的费用是2200元/年),为了能不放弃该网站,所以我又把打赏链接放上来啦~所有打赏金额都会被记账并投入博客维护中,感谢厚爱,多多关照~)

原文  https://www.liuchuo.net/archives/4988
正文到此结束
Loading...