java依赖冲突实践

在平时开发中,也许很多人在引入了某些依赖后会发现运行时报出这样的异常:

java依赖冲突实践

看到这种底层包的报错,我们通常无从下手,这时候可以考虑是依赖冲突导致的问题。

包冲突排查流程:

· 检查确认是不是包冲突(通常一些官方包例如 springframework 之类的找不到某些方法,可以尝试看看是否包冲突)

· gradle 打命令 gradlew -dependencies
· maven 命令是 maven dependency:tree

对比正常的项目中,疑似问题包版本是否对不上,有时候包依赖可能会被强制转成更高版本,就像这种。。

java依赖冲突实践

· 如果发现对不上,就需要使用对应正常的版本来试试,其中一个办法就是在自己的 build.gradle 或者 pom.xml 配置文件中配置强制使用某个版本,例如下列配置是在 build.gradle 的全局配置:

// 强制使用 1.1.7 版本的 logback
configurations.all {
    resolutionStrategy.cacheChangingModulesFor 0, 'seconds'
    resolutionStrategy.cacheDynamicVersionsFor 0, 'seconds'
    resolutionStrategy {
        force 'ch.qos.logback:logback-classic:1.1.7'
        force 'ch.qos.logback:logback-core:1.1.7'
    }
}

原文 

https://segmentfault.com/a/1190000021983225

本站部分文章源于互联网,本着传播知识、有益学习和研究的目的进行的转载,为网友免费提供。如有著作权人或出版方提出异议,本站将立即删除。如果您对文章转载有任何疑问请告之我们,以便我们及时纠正。

PS:推荐一个微信公众号: askHarries 或者qq群:474807195,里面会分享一些资深架构师录制的视频录像:有Spring,MyBatis,Netty源码分析,高并发、高性能、分布式、微服务架构的原理,JVM性能优化这些成为架构师必备的知识体系。还能领取免费的学习资源,目前受益良多

转载请注明原文出处:Harries Blog™ » java依赖冲突实践

赞 (0)
分享到:更多 ()

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址